// readme

phase2 (formerly known as “as2-lib”)

If this project saved you some time or made your day a little easier, a star would mean a lot — it helps others find it too.

AS2 is a transport protocol specified in RFC 4130. AS2 version 1.1 adding compression is specified in RFC 5402. The MDN is specified in RFC 3798. Algorithm names are defined in RFC 5751 (S/MIME 3.2) which supersedes RFC 3851 (S/MIME 3.1);

See the Wiki for all details. It also contains License details.

This library is a fork of OpenAS2 which did not release updates since 2010 (as per August 2015 they are on GitHub at https://github.com/OpenAS2/OpenAs2App). I then split the project into a common library part (the “as2-lib” submodule) and a server part (the “as2-server” submodule) which contains a stand alone (socket) server. The library project also contains a simple AS2 client which can…